summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-21 08:07:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-21 09:53:34 +0200
commit157567669bdf40edd1534a5fddeab22f90162581 (patch)
treec030bf62ee5e925c7e3c0b1dca4e7cb13d4cccd2 /dev-python/python-dotenv/python-dotenv-0.18.0.ebuild
parentdev-python/tempora: Bump to 4.1.1 (diff)
downloadgentoo-157567669bdf40edd1534a5fddeab22f90162581.tar.gz
gentoo-157567669bdf40edd1534a5fddeab22f90162581.tar.bz2
gentoo-157567669bdf40edd1534a5fddeab22f90162581.zip
dev-python/python-dotenv: Bump to 0.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dotenv/python-dotenv-0.18.0.ebuild')
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.18.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild
new file mode 100644
index 000000000000..3fd9aa665e52
--- /dev/null
+++ b/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Manage .env files"
+HOMEPAGE="https://github.com/theskumar/python-dotenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+
+DEPEND="
+ test? (
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sh-1.09[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests --install pytest