summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-20 21:15:01 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-20 21:16:58 +0200
commit8d9fd841e48b8fceca9efd6a13bd1e797219b228 (patch)
treeddc8702d047a26cd0e27465fa03b67cb2c181ecb /dev-python/python-dotenv
parentprofiles: mask libreoffice-bin on x32 (diff)
downloadgentoo-8d9fd841e48b8fceca9efd6a13bd1e797219b228.tar.gz
gentoo-8d9fd841e48b8fceca9efd6a13bd1e797219b228.tar.bz2
gentoo-8d9fd841e48b8fceca9efd6a13bd1e797219b228.zip
dev-python/python-dotenv: make sure tests find "dotenv" in PATH
Closes: https://bugs.gentoo.org/743784 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/python-dotenv')
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.14.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
index f73be0464463..facf646f4b77 100644
--- a/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
+++ b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
@@ -27,3 +27,10 @@ DEPEND="test? (
DOCS=( CHANGELOG.md README.md )
distutils_enable_tests pytest
+
+python_test() {
+ # Tests call the "dotenv" command which needs to be in PATH
+ # https://bugs.gentoo.org/743784
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}