summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-11-29 21:34:07 +0100
committerPacho Ramos <pacho@gentoo.org>2016-11-29 21:45:31 +0100
commite0080102e0e227828b70549f64f70d485622d723 (patch)
treedd9e60f515d1f2b8325029c7be2f3fe0acfd66b3 /dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild
parentdev-libs/libixion: Remove old (diff)
downloadgentoo-e0080102e0e227828b70549f64f70d485622d723.tar.gz
gentoo-e0080102e0e227828b70549f64f70d485622d723.tar.bz2
gentoo-e0080102e0e227828b70549f64f70d485622d723.zip
dev-python/python-dsv: Apply Debian patches also fixing wxpython3 compat (#601178)
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild')
-rw-r--r--dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild b/dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..9543c62d1794
--- /dev/null
+++ b/dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for importing and exporting DSV files"
+HOMEPAGE="http://python-dsv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/DSV-${PV}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/wxpython:3.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/DSV-${PV}"
+
+PATCHES=(
+ # From Debian
+ "${FILESDIR}"/${P}-env.patch
+ "${FILESDIR}"/${P}-unicode.patch
+ "${FILESDIR}"/${P}-wx-namespace.patch
+ "${FILESDIR}"/${P}-wxpython30.patch
+)