summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-10-06 15:10:48 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-10-06 15:10:48 +0300
commit5c6c757ce3dd31e9ea90b80fc073ce729ae48595 (patch)
tree10e2cf3ad03b70594d2bad2ce44dbed6f05cc7c7 /dev-python/python-efl
parentdev-util/cbindgen: drop virtual/cargo (diff)
downloadgentoo-5c6c757ce3dd31e9ea90b80fc073ce729ae48595.tar.gz
gentoo-5c6c757ce3dd31e9ea90b80fc073ce729ae48595.tar.bz2
gentoo-5c6c757ce3dd31e9ea90b80fc073ce729ae48595.zip
dev-python/python-efl: bump to 1.23.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/python-efl')
-rw-r--r--dev-python/python-efl/Manifest1
-rw-r--r--dev-python/python-efl/python-efl-1.23.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/python-efl/Manifest b/dev-python/python-efl/Manifest
index 376609705b7b..ec73549af53c 100644
--- a/dev-python/python-efl/Manifest
+++ b/dev-python/python-efl/Manifest
@@ -1 +1,2 @@
DIST python-efl-1.22.0.tar.xz 9523624 BLAKE2B b1b7573da8546f580dcd06be03e4746f2e991245c7bbc3477090c5a9365225bca663454a202f8e05ec6c73cbfb7496ee5f92bc2a9997900e6709b01017740db6 SHA512 27e29af764166e803ce6a833c8249a91226a4315dd658631cec57513befccdc9407b04b452054ceab3f77b429d899095b49dbada2e0fd1a63ff6059ef200e497
+DIST python-efl-1.23.0.tar.xz 9524832 BLAKE2B d738d3481a0805490c756d38fe169e7d54d9b4c8d6b18ba45265db029b28e59eec8d711675c3fcd52500e19cda8cabc49fb0a2d052d2b9be7800ff9f6dc78f75 SHA512 b2c4389795d704b8f0d8f2d0703b90b09daaeacf7a2d4b372d86f9e0b8f9e2f5b465f8651a0da7cb4bc1800357c317b9cb737afcb415fc0a4cdf4cbed62bdf85
diff --git a/dev-python/python-efl/python-efl-1.23.0.ebuild b/dev-python/python-efl/python-efl-1.23.0.ebuild
new file mode 100644
index 000000000000..7721035b78bb
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.23.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Enlightenment Foundation Libraries"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/python_bindings_for_efl/"
+SRC_URI="https://download.enlightenment.org/rel/bindings/python/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="=dev-libs/efl-1.23*
+ dev-python/dbus-python[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/cython-0.28.4[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )"
+
+src_prepare() {
+ default
+
+ # Tries to download a file under /tmp
+ rm tests/ecore/test_09_file_download.py || die
+
+ # Tries to use that file which failed to download
+ rm tests/ecore/test_10_file_monitor.py || die
+
+ # Needs an active internet connection
+ rm tests/ecore/test_11_con.py || die
+
+ # Test fails because of deleted files above
+ sed -i 's/>= 13/>= 10/g' tests/ecore/test_08_exe.py || die
+
+ # Make tests verbose
+ sed -i 's:verbosity=1:verbosity=3:' tests/00_run_all_tests.py || die
+}
+
+python_compile_all() {
+ if use doc ; then
+ esetup.py build_doc --build-dir "${S}"/build/doc/
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd tests/ || die
+ ${EPYTHON} 00_run_all_tests.py --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ./build/doc/html/. )
+ distutils-r1_python_install_all
+}