summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2018-05-23 10:49:41 +0300
committerAaron Bauman <bman@gentoo.org>2018-05-25 18:50:23 -0400
commitd851525459f876f2af1dfb71be117b0f20c7900f (patch)
tree36082d1f8a2dcfdccc12231c038b981c32a4ee76 /dev-python/python-efl
parentwww-apps/redmine: version bump and fixes (diff)
downloadgentoo-d851525459f876f2af1dfb71be117b0f20c7900f.tar.gz
gentoo-d851525459f876f2af1dfb71be117b0f20c7900f.tar.bz2
gentoo-d851525459f876f2af1dfb71be117b0f20c7900f.zip
dev-python/python-efl: bump to 1.20.0
Add myself as proxy-maintainer. Bump EAPI to 7. Clean metadata.xml file. Package-Manager: Portage[mgorny]-2.3.36.1 Closes: https://github.com/gentoo/gentoo/pull/8530
Diffstat (limited to 'dev-python/python-efl')
-rw-r--r--dev-python/python-efl/Manifest1
-rw-r--r--dev-python/python-efl/metadata.xml16
-rw-r--r--dev-python/python-efl/python-efl-1.20.0.ebuild71
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-python/python-efl/Manifest b/dev-python/python-efl/Manifest
index e40092e6ee11..59edc28ae699 100644
--- a/dev-python/python-efl/Manifest
+++ b/dev-python/python-efl/Manifest
@@ -1,2 +1,3 @@
DIST python-efl-1.17.0.tar.xz 8835228 BLAKE2B 0380bfa9ac8a9553bf3c1fa4ed7f4c65007e75ebe159427aff12cfd7359859b42e56b5ebcb02af97324696c3addbc9fe31b4dbe23d4dbe2574b056e4e6d23297 SHA512 ff610dbacf72853b6c8fb1dcd41451f97156845efeb67a2d5d6c35d9b20c0f024c145a26a579f675bc2ad5844c23e58d8b21a09374aa195174f1a0c6316c0de4
DIST python-efl-1.18.0.tar.xz 8927932 BLAKE2B c1b41e1316c78fc42cf21541aba386dce799f1ec26549dda8c547de4cf47870a100070bb442d21116ce956808bcf948eba96601343512ba61fb1fc472e2574be SHA512 c1fc8d4129c2ac61b367ad373ad676a60cf0aed4c9150104d7e81bf464c44a3a5ae555d2298bbf1bdf6a3d6ba3b7d934af390e36755a1516972db2675d920c2b
+DIST python-efl-1.20.0.tar.xz 8984492 BLAKE2B 526c530d7b8dad59d01cefcbb6cad2710cb46c3b62eb0b2746c3552c8c1ef42cc4691072fbbce16a8a3b6ea9d6b5651a3645ca739e569a0f4db3dd9988ddf2fa SHA512 93d8d6c990350074e203bf3632d92b5253f34f318b30357b05ab5ab73a9f6656d127ff0c1831af1bf7c736822b483c12754085e52103eb0e41362cc28db5651f
diff --git a/dev-python/python-efl/metadata.xml b/dev-python/python-efl/metadata.xml
index 6f49eba8f496..1b546bfae6dd 100644
--- a/dev-python/python-efl/metadata.xml
+++ b/dev-python/python-efl/metadata.xml
@@ -1,5 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>juippis@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ EFL is a collection of libraries for handling many common tasks a
+ developer man have such as data structures, communication,
+ rendering, widgets and more.
+
+ PYTHON-EFL are the python bindings for the whole EFL stack (eo,
+ evas, ecore, edje, emotion, ethumb and elementary)
+ </longdescription>
</pkgmetadata>
diff --git a/dev-python/python-efl/python-efl-1.20.0.ebuild b/dev-python/python-efl/python-efl-1.20.0.ebuild
new file mode 100644
index 000000000000..0fc4a05569d3
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.20.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Enlightenment Foundation Libraries"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/python_bindings_for_efl/"
+SRC_URI="https://download.enlightenment.org/rel/bindings/python/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-libs/efl-${PV}
+ >=dev-python/dbus-python-0.83[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-python/cython-0.21[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ >=dev-python/sphinx-1.1[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+"
+
+python_compile_all() {
+ if use doc ; then
+ # Point sphinx to right location with built sources
+ sed -i 's|"../build/"+d|"'"${BUILD_DIR}"'/lib"|g' doc/conf.py || die
+
+ esetup.py build_doc --build-dir "${S}"/build/doc/
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${S}"/tests || die
+
+ # Tries to download a file under /tmp
+ rm -f ecore/test_09_file_download.py || die
+
+ # Tries to use that file which failed to download
+ rm -f ecore/test_10_file_monitor.py || die
+
+ # Seems to need connman up and running during the test, requires:
+ # net-misc/connman
+ # dev-libs/efl[connman]
+ rm -f ecore/test_11_con.py || die
+
+ # Test fails because of deleted files above
+ sed -i 's/>= 13/>= 10/g' ecore/test_08_exe.py || die
+
+ sed -i 's:verbosity=1:verbosity=3:' 00_run_all_tests.py || die
+ ${PYTHON} 00_run_all_tests.py --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc ; then
+ local HTML_DOCS=( build/doc/html/. )
+ fi
+
+ distutils-r1_python_install_all
+}