summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-25 20:02:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-25 20:04:01 +0200
commit3f4ea83c1758f7e894edb658f28dd698c613b525 (patch)
tree6923f98f60d7f6946e878fcf203533f9be22ed6b /dev-python/python-email-validator
parentdev-util/xfce4-dev-tools: Bump to 4.17.0 (diff)
downloadgentoo-3f4ea83c1758f7e894edb658f28dd698c613b525.tar.gz
gentoo-3f4ea83c1758f7e894edb658f28dd698c613b525.tar.bz2
gentoo-3f4ea83c1758f7e894edb658f28dd698c613b525.zip
dev-python/python-email-validator: Skip more internet tests
Closes: https://bugs.gentoo.org/804211 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-email-validator')
-rw-r--r--dev-python/python-email-validator/python-email-validator-1.1.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/python-email-validator/python-email-validator-1.1.3.ebuild b/dev-python/python-email-validator/python-email-validator-1.1.3.ebuild
index 4755828be07c..37514f3ad4d8 100644
--- a/dev-python/python-email-validator/python-email-validator-1.1.3.ebuild
+++ b/dev-python/python-email-validator/python-email-validator-1.1.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -29,6 +29,10 @@ python_test() {
tests/test_main.py::test_deliverability_fails
tests/test_main.py::test_validate_email__with_caching_resolver
tests/test_main.py::test_validate_email__with_configured_resolver
+ # these tests rely on example.com being resolvable
+ tests/test_main.py::test_main_single_good_input
+ tests/test_main.py::test_main_multi_input
+ tests/test_main.py::test_main_input_shim
)
epytest ${deselect[@]/#/--deselect }