summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-09-24 16:00:11 -0700
committerZac Medico <zmedico@gentoo.org>2017-09-24 16:08:06 -0700
commit204be586079a01aebce5ceccc588df36fadc1604 (patch)
tree6ef386948e53767f230c20647bc3adc4be6319bb /dev-python/python-engineio/python-engineio-1.7.0.ebuild
parentsys-apps/busybox: use https for git repo (diff)
downloadgentoo-204be586079a01aebce5ceccc588df36fadc1604.tar.gz
gentoo-204be586079a01aebce5ceccc588df36fadc1604.tar.bz2
gentoo-204be586079a01aebce5ceccc588df36fadc1604.zip
dev-python/python-engineio: version bump to 1.7.0
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-python/python-engineio/python-engineio-1.7.0.ebuild')
-rw-r--r--dev-python/python-engineio/python-engineio-1.7.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-engineio/python-engineio-1.7.0.ebuild b/dev-python/python-engineio/python-engineio-1.7.0.ebuild
new file mode 100644
index 000000000000..6f3b26b71d31
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-1.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://${PN}.readthedocs.org/ https://github.com/miguelgrinberg/${PN}/ https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}