summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-07-03 13:03:07 -0700
committerZac Medico <zmedico@gentoo.org>2018-07-03 14:54:35 -0700
commit8f7c12a31cfaaef80f4ef0fad61c647174dbc373 (patch)
tree33ed4789239d06393473bdf7b66f4cc8b15f2d96 /dev-python/python-engineio/python-engineio-2.2.0.ebuild
parentdev-lang/squirrel: declare used CMake variables, bug #659880 (diff)
downloadgentoo-8f7c12a31cfaaef80f4ef0fad61c647174dbc373.tar.gz
gentoo-8f7c12a31cfaaef80f4ef0fad61c647174dbc373.tar.bz2
gentoo-8f7c12a31cfaaef80f4ef0fad61c647174dbc373.zip
dev-python/python-engineio: version bump to 2.2.0
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/python-engineio/python-engineio-2.2.0.ebuild')
-rw-r--r--dev-python/python-engineio/python-engineio-2.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-engineio/python-engineio-2.2.0.ebuild b/dev-python/python-engineio/python-engineio-2.2.0.ebuild
new file mode 100644
index 000000000000..780c7de65f76
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://python-engineio.readthedocs.org/ https://github.com/miguelgrinberg/python-engineio/ https://pypi.org/project/python-engineio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}