summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-04-21 18:16:20 -0700
committerZac Medico <zmedico@gentoo.org>2020-04-21 18:17:51 -0700
commitcb8a46a709ebda063ebc71b6c84f19d39648e98d (patch)
tree76d7ca05871e435f75590abf0139d2227df5af21 /dev-python/python-engineio/python-engineio-3.12.1.ebuild
parentnet-vpn/tailscale-0.98_p0: Version bump (diff)
downloadgentoo-cb8a46a709ebda063ebc71b6c84f19d39648e98d.tar.gz
gentoo-cb8a46a709ebda063ebc71b6c84f19d39648e98d.tar.bz2
gentoo-cb8a46a709ebda063ebc71b6c84f19d39648e98d.zip
dev-python/python-engineio: Bump to version 3.12.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio/python-engineio-3.12.1.ebuild')
-rw-r--r--dev-python/python-engineio/python-engineio-3.12.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-engineio/python-engineio-3.12.1.ebuild b/dev-python/python-engineio/python-engineio-3.12.1.ebuild
new file mode 100644
index 000000000000..c22628414e8f
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-3.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://python-engineio.readthedocs.org/ https://github.com/miguelgrinberg/python-engineio/ https://pypi.org/project/python-engineio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}