summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-16 08:52:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-16 10:29:29 +0200
commitb1946b7987660a09d6f0a66526d44ab87987fd0d (patch)
tree370d47083303bf8aaa086d388d818d82aa0fef64 /dev-python/python-engineio
parentdev-python/sqlalchemy: Bump to 1.4.8 (diff)
downloadgentoo-b1946b7987660a09d6f0a66526d44ab87987fd0d.tar.gz
gentoo-b1946b7987660a09d6f0a66526d44ab87987fd0d.tar.bz2
gentoo-b1946b7987660a09d6f0a66526d44ab87987fd0d.zip
dev-python/python-engineio: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-4.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 66d67a727785..6caadd23bd2e 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,2 +1,3 @@
DIST python-engineio-3.12.1.tar.gz 37158 BLAKE2B a3f75b0ec197248029a2a257eee7694298d916bc444705df7a941e8106d09e5bc802cd612c88e526883083730797e4835e13db93121714a701af17d894ac53cf SHA512 f81012e264025dc24845986e67c7d19d46048e072a409483a130630e07efb84e831e188d3f277dd0f7d26351015009afcef0d2058bb19dacee68d6c56837fa1d
DIST python-engineio-4.0.1.gh.tar.gz 296000 BLAKE2B dc3b2c3f25ebbfb9d795e3c08e82b2e001fbc785dfb1666f137d8b261b65a90a15af7527917bdd9c636f076f75e01c65b498145ae5051649e1264eb9339d9f7e SHA512 83886ed1a60465127b7eb42a8437196cd68f4c538076237e4f64ff36f6fb02d1e45bd6730d4bb6209c931e05b4c2e10bae60451d1d4644071178ff44a73805e9
+DIST python-engineio-4.1.0.gh.tar.gz 296431 BLAKE2B 5ab267aba4dc6e49d26166b661da5b40961d328efb92dbcb653a405f62956f33b28dbf48cd891d0e74314da998be477f917dd6eabdf154877cd80077e4172c9f SHA512 5dea0ffc24138664216eefd6f917280d6199e4c2661a2e41622bb7f4cf03467d60d555e5c28ba23c35f59ae8b549902d235308242bbc5607ac91fd61580e0c4f
diff --git a/dev-python/python-engineio/python-engineio-4.1.0.ebuild b/dev-python/python-engineio/python-engineio-4.1.0.ebuild
new file mode 100644
index 000000000000..789212fa520e
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest