summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-geoclue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-geoclue')
-rw-r--r--dev-python/python-geoclue/Manifest1
-rw-r--r--dev-python/python-geoclue/metadata.xml8
-rw-r--r--dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-geoclue/Manifest b/dev-python/python-geoclue/Manifest
new file mode 100644
index 000000000000..bad62811eb71
--- /dev/null
+++ b/dev-python/python-geoclue/Manifest
@@ -0,0 +1 @@
+DIST python-geoclue-0.1.0.tar.gz 61062 SHA256 51748c22244f974854eacbf518a11a72cdf76045b7ab9cae44b7a592dfa4e259 SHA512 844c877038f9b8db096a33605be16f8aaea8e66fa84e3a42927f103afa9c8ab565b28cc69b9d02d30bfd02a20e6e20e7fdf28a7d06900db9d288775bb153c533 WHIRLPOOL b59fc942e9686e55f8a6d2aab2a335f51b0f8de4a13bd6d9f3945cabd5133fffd125b7373f3dc9c9b7941d66ef27e41aa832cf3e2f1ca332dfd6376b5dedaa08
diff --git a/dev-python/python-geoclue/metadata.xml b/dev-python/python-geoclue/metadata.xml
new file mode 100644
index 000000000000..6c90e346eb69
--- /dev/null
+++ b/dev-python/python-geoclue/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild b/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..894304dbfc7d
--- /dev/null
+++ b/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Geoclue python module"
+HOMEPAGE="http://live.gnome.org/gtg/soc/python_geoclue/"
+SRC_URI="http://www.paulocabido.com/soc/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="test"
+
+RDEPEND="
+ app-misc/geoclue:0
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]"
+DEPEND="test? ( app-misc/geoclue:0 )"
+
+S="${WORKDIR}"/${PN}
+
+python_prepare_all() {
+ use test && DISTUTILS_NO_PARALLEL_BUILD=true
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ VIRTUALX_COMMAND="${PYTHON}"
+ cd "${BUILD_DIR}" || die
+ virtualmake "${S}"/tests/test.py
+}