summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-10 18:14:37 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-10 18:14:45 +0100
commit428b8a3de05f2e1863b2adb0e8a5ccc2120a0b29 (patch)
tree6a15554a92506c883b2500f4aa684d56222665f1 /dev-python/python-gflags/python-gflags-3.0.2.ebuild
parentsys-devel/llvm: Fix missing ||die on FreeBSD-added code (diff)
downloadgentoo-428b8a3de05f2e1863b2adb0e8a5ccc2120a0b29.tar.gz
gentoo-428b8a3de05f2e1863b2adb0e8a5ccc2120a0b29.tar.bz2
gentoo-428b8a3de05f2e1863b2adb0e8a5ccc2120a0b29.zip
dev-python/python-gflags: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-gflags/python-gflags-3.0.2.ebuild')
-rw-r--r--dev-python/python-gflags/python-gflags-3.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-gflags/python-gflags-3.0.2.ebuild b/dev-python/python-gflags/python-gflags-3.0.2.ebuild
new file mode 100644
index 000000000000..d26a4bfc7892
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-3.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Python argument parsing library"
+HOMEPAGE="https://github.com/gflags/python-gflags"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-scripts-install.patch
+)