summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-07-16 19:47:55 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-07-16 20:34:37 -0700
commit76dcbf9575307030c97c75b842d02c7e1ea004e9 (patch)
tree3240caea4c9c5a8647149d0d5283060d3d8f43e1 /dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild
parentprofiles/: Fix bad entry in package.mask for dev-perl/libvorbis-perl (diff)
downloadgentoo-76dcbf9575307030c97c75b842d02c7e1ea004e9.tar.gz
gentoo-76dcbf9575307030c97c75b842d02c7e1ea004e9.tar.bz2
gentoo-76dcbf9575307030c97c75b842d02c7e1ea004e9.zip
dev-python/python-gflags: Revbump, add python3_7, move to EAPI=7
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild')
-rw-r--r--dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild b/dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild
new file mode 100644
index 000000000000..645b558ba52b
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Python argument parsing library"
+HOMEPAGE="https://github.com/google/python-gflags"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-script-install.patch
+)
+
+python_test() {
+ # note: each test needs to be run separately, otherwise they fail
+ "${PYTHON}" -m gflags._helpers_test -v || die
+ "${PYTHON}" -m gflags.flags_formatting_test -v || die
+ "${PYTHON}" -m gflags.flags_unicode_literals_test -v || die
+}