summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-gtkmvc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-gtkmvc')
-rw-r--r--dev-python/python-gtkmvc/Manifest1
-rw-r--r--dev-python/python-gtkmvc/metadata.xml9
-rw-r--r--dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild35
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-gtkmvc/Manifest b/dev-python/python-gtkmvc/Manifest
new file mode 100644
index 000000000000..fb43ad21145c
--- /dev/null
+++ b/dev-python/python-gtkmvc/Manifest
@@ -0,0 +1 @@
+DIST python-gtkmvc-1.99.1.tar.gz 1426052 SHA256 a8a74fb0a21d9e229950927a906f5f83ee19e459547138b360a6c60418667ab7 SHA512 f82bbe0f769a57120d3858f77a6531778f4ffbf16191a2f8b3f0cd7da047f756db560e2896504530a92d142c27d61cd010c0ceada059e5dce9428b58950490a0 WHIRLPOOL ded448a1e9ddf4380ea0b0b00fea1f79550a27dc91f05bbf978e00477a7045313507e4baa3c920b24df0c0519fd716bdf8e3c30acd1a16ad7b6db6c377a3ec28
diff --git a/dev-python/python-gtkmvc/metadata.xml b/dev-python/python-gtkmvc/metadata.xml
new file mode 100644
index 000000000000..fad314aca6b6
--- /dev/null
+++ b/dev-python/python-gtkmvc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <!-- <herd>gnome</herd> -->
+ <upstream>
+ <remote-id type="sourceforge">pygtkmvc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild b/dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild
new file mode 100644
index 000000000000..0f4080f779a9
--- /dev/null
+++ b/dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="model-view-controller (MVC) implementation for pygtk"
+HOMEPAGE="http://pygtkmvc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pygtkmvc/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=">=dev-python/pygtk-2.24.0"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ dodoc README
+ use doc && dohtml -r docs/_build/html/
+
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples/
+ insinto usr/share/doc/${P}/
+ doins -r examples/
+ fi
+}