summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zachary.medico@sony.com>2019-06-18 19:00:28 -0700
committerZac Medico <zmedico@gentoo.org>2019-06-24 18:33:40 -0700
commiteaaa480af5bb37b1087d9397e7cf8fb962f0c538 (patch)
treec8b53a9dfd7a12d00345c06f825b7d595214912f /dev-python/python-jose/python-jose-3.0.1.ebuild
parentdev-python/backports-tempfile: New package (diff)
downloadgentoo-eaaa480af5bb37b1087d9397e7cf8fb962f0c538.tar.gz
gentoo-eaaa480af5bb37b1087d9397e7cf8fb962f0c538.tar.bz2
gentoo-eaaa480af5bb37b1087d9397e7cf8fb962f0c538.zip
dev-python/python-jose: New package
Bug: https://bugs.gentoo.org/688034 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/python-jose/python-jose-3.0.1.ebuild')
-rw-r--r--dev-python/python-jose/python-jose-3.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-jose/python-jose-3.0.1.ebuild b/dev-python/python-jose/python-jose-3.0.1.ebuild
new file mode 100644
index 000000000000..e304330420f5
--- /dev/null
+++ b/dev-python/python-jose/python-jose-3.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A JavaScript Object Signing and Encryption (JOSE) implementation in Python"
+HOMEPAGE="https://github.com/mpdavis/python-jose https://pypi.org/project/python-jose/"
+# pypi tarball lacks unit tests
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/mpdavis/python-jose/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.3.1[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}