summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-20 14:06:54 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-20 14:23:39 -0500
commit10441a0e5bd75ab94e912f7cbc075c2429e52f9b (patch)
treec3ffe2a56c7c0c004fa11005147d679583720897 /dev-python/python-keystoneclient
parentdev-util/bpftrace-0.10.0-r1: Fix build with bcc-0.15.0 (diff)
downloadgentoo-10441a0e5bd75ab94e912f7cbc075c2429e52f9b.tar.gz
gentoo-10441a0e5bd75ab94e912f7cbc075c2429e52f9b.tar.bz2
gentoo-10441a0e5bd75ab94e912f7cbc075c2429e52f9b.zip
dev-python/python-keystoneclient: 4.0.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-keystoneclient')
-rw-r--r--dev-python/python-keystoneclient/Manifest1
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-4.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/python-keystoneclient/Manifest b/dev-python/python-keystoneclient/Manifest
index 208f1f9ac6e7..8f79c605e4dd 100644
--- a/dev-python/python-keystoneclient/Manifest
+++ b/dev-python/python-keystoneclient/Manifest
@@ -1 +1,2 @@
DIST python-keystoneclient-3.21.0.tar.gz 318108 BLAKE2B 3708b8f464fea1d09edbf7d887bb0a73cb096319c38604381fb60ec33cdb41896a145a5896ff3cc094f055bd30a47e04e30c1238d278edea57e89da8757047f9 SHA512 d705a6183be9cbfb0743da7ef535620e92ea0b4161d87b6c21ef1298ae5cd9e95e280163f286c60565154d22a2374bf5cd3d51f6274e212499e58569dc3a0f55
+DIST python-keystoneclient-4.0.0.tar.gz 313891 BLAKE2B 886f354ea29b4bb8886bde1c337e619403f81ee608079777f1e96bf55e936fb7bef48194d721b14857043e1c878f2f2c925483dc0641bb5c25afd6af1536fce9 SHA512 6c094327b4c8bcb32c42463a3abe412230c514c59a5b45387da99689385780f530669979b6aa06ee03450a1386ff089bfc69c24c625e56ed46ab093e6f58153f
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-4.0.0.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-4.0.0.ebuild
new file mode 100644
index 000000000000..623d0b7f54c1
--- /dev/null
+++ b/dev-python/python-keystoneclient/python-keystoneclient-4.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Client Library for OpenStack Identity"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+RESTRICT="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+#PATCHES=(
+#)
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}