summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-14 02:50:48 +0000
committerSam James <sam@gentoo.org>2022-05-14 02:51:49 +0000
commit9a48f929d360f6e61e305898850339774b7fe663 (patch)
tree1058d3aee1f2c5509e2cf38167f5406e181e5a14 /dev-python/python-ldap/python-ldap-9999.ebuild
parentdev-python/python-ldap: added openldap 2.6 support (diff)
downloadgentoo-9a48f929d360f6e61e305898850339774b7fe663.tar.gz
gentoo-9a48f929d360f6e61e305898850339774b7fe663.tar.bz2
gentoo-9a48f929d360f6e61e305898850339774b7fe663.zip
dev-python/python-ldap: add 3.4.0_p20220420
Snapshot because a bunch of commits were needed to fix OpenLDAP 2.6+ compat and then there were some serious bugfixes too. Closes: https://bugs.gentoo.org/835637 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/python-ldap/python-ldap-9999.ebuild')
-rw-r--r--dev-python/python-ldap/python-ldap-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/python-ldap/python-ldap-9999.ebuild b/dev-python/python-ldap/python-ldap-9999.ebuild
index a01b853838d7..6bcb8bc92611 100644
--- a/dev-python/python-ldap/python-ldap-9999.ebuild
+++ b/dev-python/python-ldap/python-ldap-9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Various LDAP-related Python modules"
@@ -22,16 +23,15 @@ LICENSE="MIT PSF-2"
SLOT="0"
IUSE="examples sasl ssl"
-# < dep on openldap for bug #835637, ldap_r is gone
RDEPEND="
>=dev-python/pyasn1-0.3.7[${PYTHON_USEDEP}]
>=dev-python/pyasn1-modules-0.1.5[${PYTHON_USEDEP}]
- <net-nds/openldap-2.6:=[sasl?,ssl?]
+ net-nds/openldap:=[sasl?,ssl?]
"
# We do not link against cyrus-sasl but we use some
# of its headers during the build.
DEPEND="
- <net-nds/openldap-2.6:=[sasl?,ssl?]
+ net-nds/openldap:=[sasl?,ssl?]
sasl? ( >=dev-libs/cyrus-sasl-2.1 )
"