summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-10 10:51:32 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-10 10:51:32 -0800
commitaf06b2ecdefd85f98395702cdff01508b4b6434f (patch)
tree72501ac83ca18b699df44e5e0731213dd369ed81 /dev-python/python-ldap
parentdev-python/python-ldap-3.2.0: Bump, py eclass helpers, py38 (diff)
downloadgentoo-af06b2ecdefd85f98395702cdff01508b4b6434f.tar.gz
gentoo-af06b2ecdefd85f98395702cdff01508b4b6434f.tar.bz2
gentoo-af06b2ecdefd85f98395702cdff01508b4b6434f.zip
dev-python/python-ldap-9999: Sync with version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/python-ldap-9999.ebuild37
1 files changed, 16 insertions, 21 deletions
diff --git a/dev-python/python-ldap/python-ldap-9999.ebuild b/dev-python/python-ldap/python-ldap-9999.ebuild
index 2e9dd826183f..108ef92cab3a 100644
--- a/dev-python/python-ldap/python-ldap-9999.ebuild
+++ b/dev-python/python-ldap/python-ldap-9999.ebuild
@@ -2,14 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
inherit distutils-r1
DESCRIPTION="Various LDAP-related Python modules"
HOMEPAGE="https://www.python-ldap.org/en/latest/
- https://pypi.org/project/python-ldap/"
+ https://pypi.org/project/python-ldap/
+ https://github.com/python-ldap/python-ldap"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/python-ldap/python-ldap.git"
inherit git-r3
@@ -20,8 +20,7 @@ fi
LICENSE="PSF-2"
SLOT="0"
-IUSE="doc examples sasl ssl test"
-RESTRICT="!test? ( test )"
+IUSE="examples sasl ssl"
# We do not need OpenSSL, it is never directly used:
# https://github.com/python-ldap/python-ldap/issues/224
@@ -33,17 +32,14 @@ RDEPEND="
"
# We do not link against cyrus-sasl but we use some
# of its headers during the build.
-DEPEND="
+BDEPEND="
>net-nds/openldap-2.4.11:=[sasl?,ssl?]
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
sasl? ( >=dev-libs/cyrus-sasl-2.1 )
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
"
+distutils_enable_tests pytest
+distutils_enable_sphinx Doc
+
python_prepare_all() {
# The live ebuild won't compile if setuptools_scm < 1.16.2 is installed
# https://github.com/pypa/setuptools_scm/issues/228
@@ -61,13 +57,6 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_compile_all() {
- if use doc; then
- sphinx-build Doc Doc/_build/html || die
- HTML_DOCS=( Doc/_build/html/. )
- fi
-}
-
python_test() {
# Run all tests which don't require slapd
local ignored_tests=(
@@ -81,9 +70,15 @@ python_test() {
t_ldap_syncrepl.py
t_slapdobject.py
)
- cd Tests || die
- py.test ${ignored_tests[@]/#/--ignore } \
+ pushd Tests >/dev/null || die
+ pytest -vv ${ignored_tests[@]/#/--ignore } \
|| die "tests failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
}
python_install_all() {