summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 22:02:50 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 22:11:13 +0100
commitb27fb1a0538d53e0a25cd456f096a1251c413692 (patch)
treed06ea88aecee18e31b57af215474a7ab53fa9e83 /dev-python/python-ldap
parentdev-python/python-iptables: Remove redundant versions (diff)
downloadgentoo-b27fb1a0538d53e0a25cd456f096a1251c413692.tar.gz
gentoo-b27fb1a0538d53e0a25cd456f096a1251c413692.tar.bz2
gentoo-b27fb1a0538d53e0a25cd456f096a1251c413692.zip
dev-python/python-ldap: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/Manifest1
-rw-r--r--dev-python/python-ldap/python-ldap-3.1.0-r1.ebuild95
2 files changed, 0 insertions, 96 deletions
diff --git a/dev-python/python-ldap/Manifest b/dev-python/python-ldap/Manifest
index d13aa9c012f1..055f928ceea2 100644
--- a/dev-python/python-ldap/Manifest
+++ b/dev-python/python-ldap/Manifest
@@ -1,2 +1 @@
-DIST python-ldap-3.1.0.tar.gz 366019 BLAKE2B 19e95ee096f40cc195257f82ccb5f882cc521561b14e77469be91e013d6b566102c6b426463e68353a3140fc96ebc622deed94929a3aa81cc14cb072440efe44 SHA512 71948cbae1c9a47f9e68fb8c6d65d91a2992261dd9aa535a0453f5733be1c2a25be1dda3c84abc6bdebab92150c89cc8caa757454331a0303de4fa46788b414a
DIST python-ldap-3.2.0.tar.gz 367645 BLAKE2B 5109f4a13644d53fff7506ad2417da6dbfd5d1c5d31cc63932338ee0bc7327b00878804764366523fc0610191126c1a1367e15fddbad481880f73d29d96d3322 SHA512 ef2833739fd57ad26d97ae5dba3bca8a47e770ff3f113d06a5bed0841f8fcbbe6cd102e75c753dfff48f5f6041f46a91c6166f3bb9ca44ef9bd643c0666c6b23
diff --git a/dev-python/python-ldap/python-ldap-3.1.0-r1.ebuild b/dev-python/python-ldap/python-ldap-3.1.0-r1.ebuild
deleted file mode 100644
index a6fe2cbd1ac6..000000000000
--- a/dev-python/python-ldap/python-ldap-3.1.0-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Various LDAP-related Python modules"
-HOMEPAGE="https://www.python-ldap.org/en/latest/
- https://pypi.org/project/python-ldap/"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/python-ldap/python-ldap.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~x86-solaris"
-fi
-
-LICENSE="PSF-2"
-SLOT="0"
-IUSE="doc examples sasl ssl test"
-RESTRICT="!test? ( test )"
-
-# We do not need OpenSSL, it is never directly used:
-# https://github.com/python-ldap/python-ldap/issues/224
-RDEPEND="
- !dev-python/pyldap
- >=dev-python/pyasn1-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.1.5[${PYTHON_USEDEP}]
- >net-nds/openldap-2.4.11:=[sasl?,ssl?]
-"
-# We do not link against cyrus-sasl but we use some
-# of its headers during the build.
-DEPEND="
- >net-nds/openldap-2.4.11:=[sasl?,ssl?]
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- sasl? ( >=dev-libs/cyrus-sasl-2.1 )
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # The live ebuild won't compile if setuptools_scm < 1.16.2 is installed
- # https://github.com/pypa/setuptools_scm/issues/228
- if [[ ${PV} == *9999* ]]; then
- rm -r .git || die
- fi
-
- if ! use sasl; then
- sed -i 's/HAVE_SASL//g' setup.cfg || die
- fi
- if ! use ssl; then
- sed -i 's/HAVE_TLS//g' setup.cfg || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build Doc Doc/_build/html || die
- HTML_DOCS=( Doc/_build/html/. )
- fi
-}
-
-python_test() {
- # Run all tests which don't require slapd
- local ignored_tests=(
- t_bind.py
- t_cext.py
- t_edit.py
- t_ldapobject.py
- t_ldap_options.py
- t_ldap_sasl.py
- t_ldap_schema_subentry.py
- t_ldap_syncrepl.py
- t_slapdobject.py
- )
- cd Tests || die
- py.test ${ignored_tests[@]/#/--ignore } \
- || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r Demo/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}