summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-22 16:24:37 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-22 16:24:58 +0100
commit3125c95cd9683f49a1a15f3008a7dd208616e6b7 (patch)
tree73c160675595c097f24102de153aec822e11e5cc /dev-python/python-lsp-server/python-lsp-server-1.9.0.ebuild
parentdev-python/whatthepatch: enable pypy3 (diff)
downloadgentoo-3125c95cd9683f49a1a15f3008a7dd208616e6b7.tar.gz
gentoo-3125c95cd9683f49a1a15f3008a7dd208616e6b7.tar.bz2
gentoo-3125c95cd9683f49a1a15f3008a7dd208616e6b7.zip
dev-python/python-lsp-server: enable more plugins on pypy
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/python-lsp-server/python-lsp-server-1.9.0.ebuild')
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.9.0.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.9.0.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.9.0.ebuild
index 878ce3b4f5d0..8bc53bf67357 100644
--- a/dev-python/python-lsp-server/python-lsp-server-1.9.0.ebuild
+++ b/dev-python/python-lsp-server/python-lsp-server-1.9.0.ebuild
@@ -31,11 +31,11 @@ RDEPEND="
>=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
>=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
>=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
>=dev-python/yapf-0.33.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
- >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
>=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
' 'python*')
)
"
@@ -44,18 +44,18 @@ BDEPEND="
>=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
dev-python/flaky[${PYTHON_USEDEP}]
>=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
>=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
>=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
>=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
>=dev-python/yapf-0.33.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
- dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
- >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
>=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
' 'python*')
)
"
@@ -86,10 +86,7 @@ python_test() {
EPYTEST_IGNORE+=(
test/plugins/test_autoimport.py
test/plugins/test_completion.py
- test/plugins/test_pylint_lint.py
test/plugins/test_rope_rename.py
- # whatthepatch required for yapf
- test/plugins/test_yapf_format.py
)
fi