summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-29 08:28:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-29 09:24:57 +0200
commitadafa42517c8083a36076f89f634ff5ab1420b4a (patch)
tree5d4eeb5fd5feced4ccda68bd8d3353f1bddc22a0 /dev-python/python-magic/python-magic-0.4.18.ebuild
parentsys-power/sispmctl: Version 4.1 (diff)
downloadgentoo-adafa42517c8083a36076f89f634ff5ab1420b4a.tar.gz
gentoo-adafa42517c8083a36076f89f634ff5ab1420b4a.tar.bz2
gentoo-adafa42517c8083a36076f89f634ff5ab1420b4a.zip
dev-python/python-magic: Bump to 0.4.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-magic/python-magic-0.4.18.ebuild')
-rw-r--r--dev-python/python-magic/python-magic-0.4.18.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-magic/python-magic-0.4.18.ebuild b/dev-python/python-magic/python-magic-0.4.18.ebuild
new file mode 100644
index 000000000000..681cb207e6ef
--- /dev/null
+++ b/dev-python/python-magic/python-magic-0.4.18.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6..9}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+# https://github.com/ahupp/python-magic/pull/178
+SRC_URI="https://github.com/ahupp/python-magic/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/file[-python]"
+BDEPEND="
+ test? ( sys-apps/file )
+"
+
+python_test() {
+ local -x LC_ALL=en_US.UTF-8
+ "${EPYTHON}" test/test.py -v || die "Tests fail with ${EPYTHON}"
+}