summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-24 00:45:15 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-24 00:45:15 -0600
commit0462489eae26ed3a4e48146d8ee3bbd477fc8dfc (patch)
tree65b7c8a1833fbd870d346ea57ad9e749b6e5d605 /dev-python/python-manilaclient/python-manilaclient-1.21.0.ebuild
parentdev-python/aodhclient: 1.0.0 bup (diff)
downloadgentoo-0462489eae26ed3a4e48146d8ee3bbd477fc8dfc.tar.gz
gentoo-0462489eae26ed3a4e48146d8ee3bbd477fc8dfc.tar.bz2
gentoo-0462489eae26ed3a4e48146d8ee3bbd477fc8dfc.zip
dev-python/python-manilaclient: 1.21.1 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/python-manilaclient/python-manilaclient-1.21.0.ebuild')
-rw-r--r--dev-python/python-manilaclient/python-manilaclient-1.21.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/python-manilaclient/python-manilaclient-1.21.0.ebuild b/dev-python/python-manilaclient/python-manilaclient-1.21.0.ebuild
new file mode 100644
index 000000000000..b80c71a39b8c
--- /dev/null
+++ b/dev-python/python-manilaclient/python-manilaclient-1.21.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Manila API"
+HOMEPAGE="https://github.com/openstack/python-manilaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}