summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 17:41:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 17:41:02 +0200
commit8f7cb7cd627bfc93a47d10a65797a470fe233436 (patch)
tree5e005d09221e12ec8ee966dde5286a471322cdd5 /dev-python/python-mimeparse/python-mimeparse-1.6.0-r3.ebuild
parentdev-python/scandir: Remove python2 (diff)
downloadgentoo-8f7cb7cd627bfc93a47d10a65797a470fe233436.tar.gz
gentoo-8f7cb7cd627bfc93a47d10a65797a470fe233436.tar.bz2
gentoo-8f7cb7cd627bfc93a47d10a65797a470fe233436.zip
dev-python/python-mimeparse: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-mimeparse/python-mimeparse-1.6.0-r3.ebuild')
-rw-r--r--dev-python/python-mimeparse/python-mimeparse-1.6.0-r3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-mimeparse/python-mimeparse-1.6.0-r3.ebuild b/dev-python/python-mimeparse/python-mimeparse-1.6.0-r3.ebuild
new file mode 100644
index 000000000000..db8e5fc6a1d8
--- /dev/null
+++ b/dev-python/python-mimeparse/python-mimeparse-1.6.0-r3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Basic functions for handling mime-types in python"
+HOMEPAGE="https://github.com/dbtsai/python-mimeparse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+python_test() {
+ "${EPYTHON}" mimeparse_test.py -v || die "Tests fail with ${EPYTHON}"
+}