summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-15 15:02:32 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-15 15:16:18 -0500
commit366b1ee5682c457058fbd1f8aa1ae501d91a1db3 (patch)
treeb739955f33aadfeeb787dffd9cfa9d58e3db57ef /dev-python/python-mistralclient
parentdev-tcltk/tcllib: Fix some test with newer tcl (diff)
downloadgentoo-366b1ee5682c457058fbd1f8aa1ae501d91a1db3.tar.gz
gentoo-366b1ee5682c457058fbd1f8aa1ae501d91a1db3.tar.bz2
gentoo-366b1ee5682c457058fbd1f8aa1ae501d91a1db3.zip
dev-python/python-mistralclient: 2.8.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-mistralclient')
-rw-r--r--dev-python/python-mistralclient/Manifest1
-rw-r--r--dev-python/python-mistralclient/python-mistralclient-3.8.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python-mistralclient/Manifest b/dev-python/python-mistralclient/Manifest
index e29597f28d6e..e99133ac31ac 100644
--- a/dev-python/python-mistralclient/Manifest
+++ b/dev-python/python-mistralclient/Manifest
@@ -1,3 +1,4 @@
DIST python-mistralclient-3.0.2.tar.gz 78255 BLAKE2B 58d9fda6ac9b87493008ebc809ae128b2e71443af854b7719928134f9802b0da7877eab79ad96b60e47f222815b4c4476ff93f43af557e79dc88c2f714e0eb3a SHA512 3f2bcdf7723e3acba9c34947fb26c2ad3814b89ee43a26d3779f4ac7ae0845c4129c98d1a5b6deca2e2dcf77aec128639af4e8e650863cc19b7c03864bae7ab4
DIST python-mistralclient-3.1.4.tar.gz 77670 BLAKE2B 37184cf32606affb1e08381c1a6f4d47a68d0dfc3abf4276110c7c667b12f8dc57f859f47561ff3368ccf36e684d63570dc1a82325f62a0d8e8e59366c7ba9e0 SHA512 dc9d79e79bf0f1829b218db43deb715ab000eb2dcf6d8cebfec912acac3b111d4dee9101aae7868d631a87fabe6014048709585e6817071c73ee95a8cd7f6baa
DIST python-mistralclient-3.8.0.tar.gz 95855 BLAKE2B 2432ad1fd80a6e4803af512a96c51381ee20652a01a3dac07b3894717c8f599760907b36dd71ed172b853be021b63971d264588d27efbff208924fd4d4871a13 SHA512 02a4ef4cfada8f2733456082c5fbe8ce055bed4b9b768093851b57df3d115323416a6087803e1a0307245f8b107d2c08348e0d027b2dc813632c1002dd947b14
+DIST python-mistralclient-3.8.1.tar.gz 95616 BLAKE2B bc7185522b24e30321c5f57b6bc31cf239873343bce66e901e8928aedbc3caef36102a8ee67e01f6b46f77cc0d708006ac69ec4147a22b72e52e01441e39eec4 SHA512 ccde34b3ac6e12137d57dbfce597a8f9c43824a8b2450af15ab065fe03469edf0787a2b91c8e5e1da78de5d9d4d20213701e992d4c41e61c459fd987461d5298
diff --git a/dev-python/python-mistralclient/python-mistralclient-3.8.1.ebuild b/dev-python/python-mistralclient/python-mistralclient-3.8.1.ebuild
new file mode 100644
index 000000000000..4ebcb5970c1c
--- /dev/null
+++ b/dev-python/python-mistralclient/python-mistralclient-3.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Mistral API"
+HOMEPAGE="https://github.com/openstack/python-mistralclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}