summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-09-02 08:45:02 +0200
committerUltrabug <ultrabug@gentoo.org>2016-09-02 08:45:02 +0200
commite6e02be79ba0dadbfc5ce954e822145d9131c2f6 (patch)
tree6a3fa9e3ffdd19d0172328ba9076cb8b78e5ceef /dev-python/python-rethinkdb/python-rethinkdb-2.3.0.ebuild
parentdev-db/rethinkdb: new package (diff)
downloadgentoo-e6e02be79ba0dadbfc5ce954e822145d9131c2f6.tar.gz
gentoo-e6e02be79ba0dadbfc5ce954e822145d9131c2f6.tar.bz2
gentoo-e6e02be79ba0dadbfc5ce954e822145d9131c2f6.zip
dev-python/python-rethinkdb: new package
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/python-rethinkdb/python-rethinkdb-2.3.0.ebuild')
-rw-r--r--dev-python/python-rethinkdb/python-rethinkdb-2.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-rethinkdb/python-rethinkdb-2.3.0.ebuild b/dev-python/python-rethinkdb/python-rethinkdb-2.3.0.ebuild
new file mode 100644
index 000000000000..7201375f675c
--- /dev/null
+++ b/dev-python/python-rethinkdb/python-rethinkdb-2.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MY_PN="rethinkdb"
+DESCRIPTION="Python driver library for the RethinkDB database server."
+HOMEPAGE="http://rethinkdb.com/api/python/"
+SRC_URI="mirror://pypi/r/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+# no tests provided on pypi distribution
+RESTRICT="test"
+S="${WORKDIR}/${MY_PN}-${PV}"