summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-24 00:52:56 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-24 00:52:56 -0600
commit15957964bde103bb504fb1591fff4f6785d0caeb (patch)
treec0f0edf6602a5e8f45b8c55511c2ad87f43a088f /dev-python/python-saharaclient/python-saharaclient-0.11.0.ebuild
parentdev-python/python-manilaclient: 1.21.1 bup (diff)
downloadgentoo-15957964bde103bb504fb1591fff4f6785d0caeb.tar.gz
gentoo-15957964bde103bb504fb1591fff4f6785d0caeb.tar.bz2
gentoo-15957964bde103bb504fb1591fff4f6785d0caeb.zip
dev-python/python-saharaclient: 1.5.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/python-saharaclient/python-saharaclient-0.11.0.ebuild')
-rw-r--r--dev-python/python-saharaclient/python-saharaclient-0.11.0.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/python-saharaclient/python-saharaclient-0.11.0.ebuild b/dev-python/python-saharaclient/python-saharaclient-0.11.0.ebuild
deleted file mode 100644
index 44ad54f77a79..000000000000
--- a/dev-python/python-saharaclient/python-saharaclient-0.11.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="This is a client for the OpenStack Sahara API, aka HADOOP"
-HOMEPAGE="https://github.com/openstack/python-saharaclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-CDEPEND="
- >=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]
- <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- >=dev-python/mock-1.2[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/python-neutronclient-2.6.0[${PYTHON_USEDEP}]
- >=dev-python/python-novaclient-2.26.0[${PYTHON_USEDEP}]
- >=dev-python/python-swiftclient-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- >=dev-python/tempest-lib-0.6.1[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
- >=dev-python/cliff-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
- !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/python-openstackclient-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-1.10.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- sed -i '/^argparse/d' requirements.txt || die
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- testr init
- testr run --parallel || die "testsuite failed under python2.7"
-}