summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-24 23:01:38 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-25 00:32:54 +0200
commit91a4827b4428bf94d7018c6b67e53730a4789739 (patch)
treeaff7e27e84482dc731cffd003ecad5f582f36371 /dev-python/python-sense-hat/python-sense-hat-2.2.0-r2.ebuild
parentdev-python/rtimulib: add python3.9 support (diff)
downloadgentoo-91a4827b4428bf94d7018c6b67e53730a4789739.tar.gz
gentoo-91a4827b4428bf94d7018c6b67e53730a4789739.tar.bz2
gentoo-91a4827b4428bf94d7018c6b67e53730a4789739.zip
dev-python/python-sense-hat: add python3.9 support
Also updated deps Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/python-sense-hat/python-sense-hat-2.2.0-r2.ebuild')
-rw-r--r--dev-python/python-sense-hat/python-sense-hat-2.2.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-sense-hat/python-sense-hat-2.2.0-r2.ebuild b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..eee4918e1a4a
--- /dev/null
+++ b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raspberry Pi Sense HAT python library"
+HOMEPAGE="https://github.com/RPi-Distro/python-sense-hat"
+SRC_URI="https://github.com/RPi-Distro/python-sense-hat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="arm arm64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/rtimulib[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"