summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-01 04:47:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-01 05:07:49 +0200
commit6498be4afdb4a82252d814c0367c8dffafe8dd58 (patch)
tree2d7257ad137aad0538d1089fd5f514aebfa49113 /dev-python/python-slugify/python-slugify-4.0.1.ebuild
parentapp-misc/mosquitto: Version bump to 1.6.10 (diff)
downloadgentoo-6498be4a.tar.gz
gentoo-6498be4a.tar.bz2
gentoo-6498be4a.zip
dev-python/python-slugify: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-slugify/python-slugify-4.0.1.ebuild')
-rw-r--r--dev-python/python-slugify/python-slugify-4.0.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/python-slugify/python-slugify-4.0.1.ebuild b/dev-python/python-slugify/python-slugify-4.0.1.ebuild
new file mode 100644
index 000000000000..979461ce2cee
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-4.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="https://github.com/un33k/python-slugify https://pypi.org/project/python-slugify/"
+SRC_URI="https://github.com/un33k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/text-unidecode[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest