summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-28 09:09:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-28 10:13:37 +0200
commitb271cb33dfa12f87a0b0d7b0343f09561b0b0f2e (patch)
tree5bb0b686a74cf80d018912bea41fc35c3a4571ae /dev-python/python-slugify
parentdev-python/mypy: Bump to 0.950 (diff)
downloadgentoo-b271cb33dfa12f87a0b0d7b0343f09561b0b0f2e.tar.gz
gentoo-b271cb33dfa12f87a0b0d7b0343f09561b0b0f2e.tar.bz2
gentoo-b271cb33dfa12f87a0b0d7b0343f09561b0b0f2e.zip
dev-python/python-slugify: Bump to 6.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-6.1.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index f8d03acf9caf..1d39ebf8161d 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1 +1,2 @@
DIST python-slugify-6.1.1.tar.gz 13259 BLAKE2B 2f85061775d9e921bf5679ab47d9a5b4fed2d2e1703aa2717e21c1d43fd1b93ef5d7060151bb4b473cd901aef16d3d905d2ca5004ae7bc61e906464bb52494a2 SHA512 2ffe8420b2f0504c57f42bf20aa0145ae521dab8d1bbefcaff1a815aa04377c7eb48eab929890915a9c9632a5c1cac4d3e7e093dcdfdda59f8ecee1ab787cbb7
+DIST python-slugify-6.1.2.tar.gz 13302 BLAKE2B 600ac1cc37cd0001ca3c08cdccb4655dd3754f7673596eada2dfb6adcb6c190f0e5644bd1cba4debf0fae42ae183b3d81acdcc09270e3ade94076d69ba25895a SHA512 3748c18d469032fc002318fbd5730b96a6f8430ff7b0b1a9afb4c19d4dd8e7528400682fa6b2fcc11ec4230917d7e7f61de290f5b199935d77d5335006af0ffb
diff --git a/dev-python/python-slugify/python-slugify-6.1.2.ebuild b/dev-python/python-slugify/python-slugify-6.1.2.ebuild
new file mode 100644
index 000000000000..8312bf675562
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-6.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/text-unidecode[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest