summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-17 19:50:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-17 20:03:08 +0100
commitf105671367c00bca80315d542b4a1e8b0dc96ac3 (patch)
tree28481790e1fb2af80fd7c76742cf267ea7de5758 /dev-python/python-slugify
parentdev-python/pikepdf: Bump to 5.0.0 (diff)
downloadgentoo-f105671367c00bca80315d542b4a1e8b0dc96ac3.tar.gz
gentoo-f105671367c00bca80315d542b4a1e8b0dc96ac3.tar.bz2
gentoo-f105671367c00bca80315d542b4a1e8b0dc96ac3.zip
dev-python/python-slugify: Bump to 6.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-6.0.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 7b0689bb709f..c19bed9e151f 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1,2 +1,3 @@
DIST python-slugify-4.0.1.tar.gz 11509 BLAKE2B b505c62c959dae3823db4441b8811ed98ec8afa0278325cb2715abb63a84b5de1506362699bc39216bbac4100ae265671f940dbbbdaf9164fd251bdaa7af462a SHA512 c1d99a9dc891c4cfa927e4d2bc5701f47b23b7882cce22350283a53c6ded18e1290196c3bb9838883c29c9cb3582e5e684edffd50dfbb4e9da9c2b821ea54bb5
DIST python-slugify-5.0.2.tar.gz 11728 BLAKE2B 701fb3f679cd4f714b5c57c14fb8cbfefa5b8268e9c4b877dd1e558e8a7dac325d69519b8e666043b70540908dcb250f561cebf0c5f444f9a3cfae34d97456b1 SHA512 79cdd1d0312c9e34b07dca2e898f177a85b31d3f290403375032ae962df61f3a9c4167f4bdf10f47afd17d544731d6961810f8a081ef615d76d8758c1207e6b7
+DIST python-slugify-6.0.1.tar.gz 12184 BLAKE2B ecc39ad73ba4bf68a630c105b22c234c9f8089c5063457c02b21ae5bbe5c021741ce754eabec51bb125ae549274b26f6cf8d986b66ce0ede5a653e70b4528712 SHA512 b97aba9f3b74009a802b1a7bd356d1eb27d239a05d8617c8f0107391e9f09e9a7cb6b45437755a1c86c4eed966e8975f74f6b760e17090d2c56e4db5935c0b69
diff --git a/dev-python/python-slugify/python-slugify-6.0.1.ebuild b/dev-python/python-slugify/python-slugify-6.0.1.ebuild
new file mode 100644
index 000000000000..a518490e8af1
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-6.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="dev-python/text-unidecode[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest