summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-09-24 16:02:03 -0700
committerZac Medico <zmedico@gentoo.org>2017-09-24 16:08:08 -0700
commit068c86ff7e365336d4a0dfbaf7ec4b7d76e3a346 (patch)
treedaae64ea438b28005915444e9eb186d798d95af0 /dev-python/python-socketio/python-socketio-1.8.0.ebuild
parentdev-python/python-engineio: version bump to 1.7.0 (diff)
downloadgentoo-068c86ff7e365336d4a0dfbaf7ec4b7d76e3a346.tar.gz
gentoo-068c86ff7e365336d4a0dfbaf7ec4b7d76e3a346.tar.bz2
gentoo-068c86ff7e365336d4a0dfbaf7ec4b7d76e3a346.zip
dev-python/python-socketio: version bump to 1.8.0
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-python/python-socketio/python-socketio-1.8.0.ebuild')
-rw-r--r--dev-python/python-socketio/python-socketio-1.8.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-socketio/python-socketio-1.8.0.ebuild b/dev-python/python-socketio/python-socketio-1.8.0.ebuild
new file mode 100644
index 000000000000..0dc7a26ee56f
--- /dev/null
+++ b/dev-python/python-socketio/python-socketio-1.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Socket.IO realtime server."
+HOMEPAGE="https://${PN}.readthedocs.org/ https://github.com/miguelgrinberg/${PN}/ https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/python-engineio-1.2.1[${PYTHON_USEDEP}]
+ !dev-python/gevent-socketio"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test || die
+}