summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-31 10:02:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-31 12:14:33 +0200
commit569c67cd3a5da42530fc40561dae50adbce8d425 (patch)
treedd7247b52975c8af48e66383eebc6e21b0f527be /dev-python/python-socks/python-socks-1.2.4.ebuild
parentdev-python/httplib2: Bump to 0.19.1 (diff)
downloadgentoo-569c67cd3a5da42530fc40561dae50adbce8d425.tar.gz
gentoo-569c67cd3a5da42530fc40561dae50adbce8d425.tar.bz2
gentoo-569c67cd3a5da42530fc40561dae50adbce8d425.zip
dev-python/python-socks: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks/python-socks-1.2.4.ebuild')
-rw-r--r--dev-python/python-socks/python-socks-1.2.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-socks/python-socks-1.2.4.ebuild b/dev-python/python-socks/python-socks-1.2.4.ebuild
new file mode 100644
index 000000000000..29375e51cbff
--- /dev/null
+++ b/dev-python/python-socks/python-socks-1.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# trio, curio are not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest