summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 19:07:15 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 19:43:28 +0200
commitbfeaf2e8bae21b4f4ae2f3dbbba71edf63170d7d (patch)
treefe01c4ad7baaca52b33a5da84faf4e2c2c5bd49d /dev-python/python-sqlparse/python-sqlparse-0.1.15.ebuild
parentdev-python/tempita: Clean old versions up (diff)
downloadgentoo-bfeaf2e8bae21b4f4ae2f3dbbba71edf63170d7d.tar.gz
gentoo-bfeaf2e8bae21b4f4ae2f3dbbba71edf63170d7d.tar.bz2
gentoo-bfeaf2e8bae21b4f4ae2f3dbbba71edf63170d7d.zip
dev-python/python-sqlparse: Clean old versions up
Diffstat (limited to 'dev-python/python-sqlparse/python-sqlparse-0.1.15.ebuild')
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.1.15.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.1.15.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.1.15.ebuild
deleted file mode 100644
index c0236391e4da..000000000000
--- a/dev-python/python-sqlparse/python-sqlparse-0.1.15.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_4 pypy )
-
-inherit distutils-r1
-
-MY_PN="${PN##python-}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A non-validating SQL parser module for Python"
-HOMEPAGE="https://code.google.com/p/python-sqlparse/ https://github.com/andialbrecht/sqlparse"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="BSD-2"
-IUSE="doc test"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )"
-# Required for running tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-S="${WORKDIR}"/${P#python-}
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- if python_is_python3; then
- 2to3 -w --no-diffs -n tests/ sqlparse/
- py.test ./tests || die "testsuite failed ${EPYTHON}"
- else
- py.test tests || die "testsuite failed under ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}