summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2016-06-05 15:13:57 +0300
committerMichał Górny <mgorny@gentoo.org>2016-06-08 09:08:02 +0200
commit0aae6361ffc47838c791b39541304e4b1be2fb84 (patch)
tree8e77cc6b199a2bf3a97260ecd917f5182e9fa401 /dev-python/python-sqlparse/python-sqlparse-0.1.19.ebuild
parentdev-util/google-perftools: version bump 2.5 (diff)
downloadgentoo-0aae6361ffc47838c791b39541304e4b1be2fb84.tar.gz
gentoo-0aae6361ffc47838c791b39541304e4b1be2fb84.tar.bz2
gentoo-0aae6361ffc47838c791b39541304e4b1be2fb84.zip
dev-python/python-sqlparse: add version 0.1.19
Pull-Request: https://github.com/gentoo/gentoo/pull/1616
Diffstat (limited to 'dev-python/python-sqlparse/python-sqlparse-0.1.19.ebuild')
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.1.19.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.1.19.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.1.19.ebuild
new file mode 100644
index 000000000000..00abdffb80f8
--- /dev/null
+++ b/dev-python/python-sqlparse/python-sqlparse-0.1.19.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN##python-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="https://code.google.com/p/python-sqlparse/ https://github.com/andialbrecht/sqlparse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+IUSE="doc test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+# Required for running tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+S="${WORKDIR}"/${P#python-}
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -w --no-diffs -n tests/ sqlparse/
+ py.test ./tests || die "testsuite failed ${EPYTHON}"
+ else
+ py.test tests || die "testsuite failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}