summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 23:39:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:08:08 -0500
commit3be754bc0bce5c7c0ea751654c3e09f5af32b2de (patch)
treee355a3c1fbe455d12ed75978ce6516c8cd334bbe /dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild
parentdev-python/os-brick: 2.8.1 bump (diff)
downloadgentoo-3be754bc0bce5c7c0ea751654c3e09f5af32b2de.tar.gz
gentoo-3be754bc0bce5c7c0ea751654c3e09f5af32b2de.tar.bz2
gentoo-3be754bc0bce5c7c0ea751654c3e09f5af32b2de.zip
dev-python/python-swiftclient: 3.7.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild')
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild
new file mode 100644
index 000000000000..7b5077f35ab4
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ )"
+RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+#PATCHES=( "${FILESDIR}/CVE-2013-6396.patch" )
+
+python_prepare_all() {
+ sed -i '/hacking/d' "${S}/test-requirements.txt" || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2_7"
+ flake8 tests && einfo "run of tests folder by flake8 passed"
+ flake8 bin/swift && einfo "run of ./bin/swift by flake8 passed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ../${P}-python2_7/doc/build/html/. )
+ distutils-r1_python_install_all
+}