summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-10-02 11:47:26 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-02 11:48:00 -0500
commit79f6f054ce64dda65cd7094d28b975371983aa8b (patch)
tree3d3ca27d84cdc84996bf2e5ce08e5477a2a62e57 /dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild
parentdev-python/cliff: remove broken doc build (diff)
downloadgentoo-79f6f054ce64dda65cd7094d28b975371983aa8b.tar.gz
gentoo-79f6f054ce64dda65cd7094d28b975371983aa8b.tar.bz2
gentoo-79f6f054ce64dda65cd7094d28b975371983aa8b.zip
dev-python/python-swiftclient: remove broken doc build
clean up old versions as well Fixes: https://bugs.gentoo.org/541776 Fixes: https://bugs.gentoo.org/696062 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild')
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild19
1 files changed, 1 insertions, 18 deletions
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild
index f897ac94fcf5..bff140f95608 100644
--- a/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild
+++ b/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
+IUSE="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/pbr[${PYTHON_USEDEP}]
@@ -27,14 +27,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
!~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
!~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
>=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
)"
RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]
>=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
@@ -47,18 +39,9 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_compile_all() {
- use doc && emake -C doc html
-}
-
python_test() {
testr init
testr run || die "tests failed under python2_7"
flake8 tests && einfo "run of tests folder by flake8 passed"
flake8 bin/swift && einfo "run of ./bin/swift by flake8 passed"
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( ../${P}-python2_7/doc/build/html/. )
- distutils-r1_python_install_all
-}