summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-17 17:11:41 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-17 17:28:14 +0100
commite379b65272e15df0ad17acaa977b951e16ed0691 (patch)
treeaf1a0bf73aa8b2c4460dc93cd05bba68cc1fdc9c /dev-python/python-termstyle/python-termstyle-0.1.10.ebuild
parentdev-python/ipdb: Add python3.5 support (diff)
downloadgentoo-e379b65272e15df0ad17acaa977b951e16ed0691.tar.gz
gentoo-e379b65272e15df0ad17acaa977b951e16ed0691.tar.bz2
gentoo-e379b65272e15df0ad17acaa977b951e16ed0691.zip
dev-python/python-termstyle: Add python3.5 support and fix QA issues
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-termstyle/python-termstyle-0.1.10.ebuild')
-rw-r--r--dev-python/python-termstyle/python-termstyle-0.1.10.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild b/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild
index a12818def643..5216c17f0b84 100644
--- a/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild
+++ b/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python{3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
inherit distutils-r1 vcs-snapshot
@@ -16,7 +17,7 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="dev-python/setuptools"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
python_prepare_all() {