summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-06-13 22:55:28 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-06-13 22:56:18 +0200
commit4b6316d52298476fe572b0e6af45f656f6c3770c (patch)
tree5c17d39ab627781f573a40a5f7c26fe5a5485eaa /dev-python/python-twitter
parentdev-util/meson: 0.41.0 version bump (diff)
downloadgentoo-4b6316d52298476fe572b0e6af45f656f6c3770c.tar.gz
gentoo-4b6316d52298476fe572b0e6af45f656f6c3770c.tar.bz2
gentoo-4b6316d52298476fe572b0e6af45f656f6c3770c.zip
dev-python/python-twitter: version and EAPI 6 bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-python/python-twitter')
-rw-r--r--dev-python/python-twitter/Manifest1
-rw-r--r--dev-python/python-twitter/python-twitter-3.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-twitter/Manifest b/dev-python/python-twitter/Manifest
index 374c858b49d5..986b8e1b0f02 100644
--- a/dev-python/python-twitter/Manifest
+++ b/dev-python/python-twitter/Manifest
@@ -1 +1,2 @@
DIST python-twitter-1.1.tar.gz 91795 SHA256 0fdc012894cda38735a48b55d4904d86b104515c1242c0c400ab350d62695c12 SHA512 e5600e1b01d72f000345d53abd08901636e888c05b397ded71918a06dde3d0f9e3e83f11cde6e2b5cdab106565c646494efb69eff78ad3daa69db65375e0ff26 WHIRLPOOL a8eb4c0decf54f8f849314f77eb618e70013f0503c40f023fe452fa6c9abdb9c2ea122a864657c0541eb8d86b853a7e92a7e02cd640e0a6d7fdabc5fc31ba11e
+DIST python-twitter-3.3.tar.gz 84696 SHA256 a9f2bd038a05ba384fa03e39949d1445349771ce7897aeb3c6d8774beba08185 SHA512 72e4133abddf86a19b8701f846df7eb99b426b8835e457455935a656f38c266fb2930d8a145d5d280ef2e0f0096511b29dcdf98b94bd53b6a661ea575cfb3265 WHIRLPOOL 49e8e217107b855beae8b62a72cc67f687e8bf0f3b5f782f891c8c162b165c32fcff158306d038805bd3e3b9c18b1353d48395983b0a57efec5494b2487410e6
diff --git a/dev-python/python-twitter/python-twitter-3.3.ebuild b/dev-python/python-twitter/python-twitter-3.3.ebuild
new file mode 100644
index 000000000000..e1dac0e5f3d9
--- /dev/null
+++ b/dev-python/python-twitter/python-twitter-3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the Twitter API"
+HOMEPAGE="https://github.com/bear/python-twitter"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Testsuite is still not convincing in its completeness
+RESTRICT="test"
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+# https://code.google.com/p/python-twitter/issues/detail?id=259&thanks=259&ts=1400334214
+python_test() {
+ esetup.py test
+}