summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-04-29 21:55:58 +0200
committerSebastian Pipping <sping@gentoo.org>2017-04-29 22:22:01 +0200
commit053e362fcce7accfe27d17cee4d68ebde1ed3e77 (patch)
tree0bbfa4876f51e93abf2db51d405c272b337ab195 /dev-python/python-xlib/python-xlib-0.19.ebuild
parentdev-ruby/activesupport: Mark ~hppa (bug #592756). (diff)
downloadgentoo-053e362fcce7accfe27d17cee4d68ebde1ed3e77.tar.gz
gentoo-053e362fcce7accfe27d17cee4d68ebde1ed3e77.tar.bz2
gentoo-053e362fcce7accfe27d17cee4d68ebde1ed3e77.zip
dev-python/python-xlib: 0.19
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/python-xlib/python-xlib-0.19.ebuild')
-rw-r--r--dev-python/python-xlib/python-xlib-0.19.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/python-xlib/python-xlib-0.19.ebuild b/dev-python/python-xlib/python-xlib-0.19.ebuild
new file mode 100644
index 000000000000..2b523c38de56
--- /dev/null
+++ b/dev-python/python-xlib/python-xlib-0.19.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A fully functional X client library for Python, written in Python"
+HOMEPAGE="https://github.com/python-xlib/python-xlib"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+# DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed -e 's:make:$(MAKE):g' -i doc/Makefile || die
+ cp -r "${FILESDIR}"/defs doc/src/ || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ cd doc || die
+ VARTEXFONTS="${T}"/fonts emake html
+ fi
+}
+
+python_test() {
+ cd test || die
+
+ local t
+ for t in *.py; do
+ "${EPYTHON}" "${t}" || die
+ done
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}