summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-22 16:21:31 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-22 16:21:31 +0100
commitc8cbdbfb0891d3da4db752fe50828b24d983fe0b (patch)
tree6e8a48a75892beca489daf1d148a45a835a82634 /dev-python/python-xlib/python-xlib-0.29.ebuild
parentpackage.mask: Last-rite games-emulation/fakenes (diff)
downloadgentoo-c8cbdbfb0891d3da4db752fe50828b24d983fe0b.tar.gz
gentoo-c8cbdbfb0891d3da4db752fe50828b24d983fe0b.tar.bz2
gentoo-c8cbdbfb0891d3da4db752fe50828b24d983fe0b.zip
dev-python/python-xlib: Bump to 0.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-xlib/python-xlib-0.29.ebuild')
-rw-r--r--dev-python/python-xlib/python-xlib-0.29.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-xlib/python-xlib-0.29.ebuild b/dev-python/python-xlib/python-xlib-0.29.ebuild
new file mode 100644
index 000000000000..576677a71c44
--- /dev/null
+++ b/dev-python/python-xlib/python-xlib-0.29.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A fully functional X client library for Python, written in Python"
+HOMEPAGE="https://github.com/python-xlib/python-xlib"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( sys-apps/texinfo )"
+
+distutils_enable_tests unittest
+
+python_compile_all() {
+ use doc && emake -C doc/info
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_install_all() {
+ use doc && doinfo doc/info/*.info
+ distutils-r1_python_install_all
+}