summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-01-22 14:41:18 +0100
committerSebastian Pipping <sping@gentoo.org>2019-01-22 14:49:11 +0100
commit8f066619c4ed9e17de9bdec08b00b6fd34550592 (patch)
tree5c28b37e399d5c6da94f8a4bcd406df4946652ec /dev-python/python-xlib
parentapp-arch/libarchive: Disable CNG, for completeness (diff)
downloadgentoo-8f066619c4ed9e17de9bdec08b00b6fd34550592.tar.gz
gentoo-8f066619c4ed9e17de9bdec08b00b6fd34550592.tar.bz2
gentoo-8f066619c4ed9e17de9bdec08b00b6fd34550592.zip
dev-python/python-xlib: Python 3.7
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'dev-python/python-xlib')
-rw-r--r--dev-python/python-xlib/python-xlib-0.23-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-xlib/python-xlib-0.23-r1.ebuild b/dev-python/python-xlib/python-xlib-0.23-r1.ebuild
new file mode 100644
index 000000000000..39686f93674b
--- /dev/null
+++ b/dev-python/python-xlib/python-xlib-0.23-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A fully functional X client library for Python, written in Python"
+HOMEPAGE="https://github.com/python-xlib/python-xlib"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( sys-apps/texinfo )"
+
+# DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc/info
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && doinfo doc/info/*.info
+ distutils-r1_python_install_all
+}