summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-05-21 19:21:23 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-21 19:21:47 -0700
commitbf5d35ac205d6fc1bb83d8557a9c998641fa59da (patch)
tree44bff9661fece25da6fd34f1f2ab03d149841443 /dev-python/python-xmlsec/python-xmlsec-1.3.8.ebuild
parentx11-apps/xisxwayland: Fix dependencies (diff)
downloadgentoo-bf5d35ac205d6fc1bb83d8557a9c998641fa59da.tar.gz
gentoo-bf5d35ac205d6fc1bb83d8557a9c998641fa59da.tar.bz2
gentoo-bf5d35ac205d6fc1bb83d8557a9c998641fa59da.zip
dev-python/python-xmlsec-1.3.8: Version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/python-xmlsec/python-xmlsec-1.3.8.ebuild')
-rw-r--r--dev-python/python-xmlsec/python-xmlsec-1.3.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-xmlsec/python-xmlsec-1.3.8.ebuild b/dev-python/python-xmlsec/python-xmlsec-1.3.8.ebuild
new file mode 100644
index 000000000000..af996d17df8e
--- /dev/null
+++ b/dev-python/python-xmlsec/python-xmlsec-1.3.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the XML Security Library"
+HOMEPAGE="https://github.com/mehcode/python-xmlsec"
+SRC_URI="https://github.com/mehcode/python-xmlsec/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/xmlsec:=
+"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+# tests fail, has been reported upstream
+# https://github.com/mehcode/python-xmlsec/issues/84
+RESTRICT=test
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s:use_scm_version=.*:version='${PV}',:" \
+ -e "/setup_requires/ d" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}