summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-03 13:44:03 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-03 13:46:44 -0500
commitde91af2e1ac8f13872225c9827bac713618de2a4 (patch)
treea43cfc4a5387235667a16c4b3907c8bd8f58f496 /dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild
parentdev-php/smarty: Version bump (diff)
downloadgentoo-de91af2e1ac8f13872225c9827bac713618de2a4.tar.gz
gentoo-de91af2e1ac8f13872225c9827bac713618de2a4.tar.bz2
gentoo-de91af2e1ac8f13872225c9827bac713618de2a4.zip
dev-python/python-zaqarclient: adding for heat
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild')
-rw-r--r--dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild b/dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild
new file mode 100644
index 000000000000..8df77396d218
--- /dev/null
+++ b/dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Zaqar API"
+HOMEPAGE="https://github.com/openstack/python-zaqarclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.0.2[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}