summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-16 16:11:52 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-16 16:21:28 -0500
commitcb6b1bdfd18dc645639855ee0e7a079181205395 (patch)
tree2c24cb30337cc10d6acc36eef0b683c7b83edf22 /dev-python/python-zunclient/python-zunclient-4.0.1.ebuild
parentdev-python/python-neutronclient: 7.1.1 bump (diff)
downloadgentoo-cb6b1bdfd18dc645639855ee0e7a079181205395.tar.gz
gentoo-cb6b1bdfd18dc645639855ee0e7a079181205395.tar.bz2
gentoo-cb6b1bdfd18dc645639855ee0e7a079181205395.zip
dev-python/python-zunclient: 4.0.1 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-zunclient/python-zunclient-4.0.1.ebuild')
-rw-r--r--dev-python/python-zunclient/python-zunclient-4.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-zunclient/python-zunclient-4.0.1.ebuild b/dev-python/python-zunclient/python-zunclient-4.0.1.ebuild
new file mode 100644
index 000000000000..b836e3a794d5
--- /dev/null
+++ b/dev-python/python-zunclient/python-zunclient-4.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Zun API"
+HOMEPAGE="https://github.com/openstack/python-zunclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.44.0[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]"