summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-19 09:44:30 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-19 09:44:30 +0200
commit4dc2976ab07906d337b56d2aec0b5e7fbc367180 (patch)
tree7e7617a36f69fe994c4a1a38b766924734de8cbd /dev-python/python3-saml
parentdev-perl/libwww-perl: Stabilize 6.600.0-r1 ppc, #833685 (diff)
downloadgentoo-4dc2976ab07906d337b56d2aec0b5e7fbc367180.tar.gz
gentoo-4dc2976ab07906d337b56d2aec0b5e7fbc367180.tar.bz2
gentoo-4dc2976ab07906d337b56d2aec0b5e7fbc367180.zip
dev-python/python3-saml: add 1.14.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python3-saml')
-rw-r--r--dev-python/python3-saml/Manifest1
-rw-r--r--dev-python/python3-saml/python3-saml-1.14.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python3-saml/Manifest b/dev-python/python3-saml/Manifest
index b4371a78cfb7..18a0b376494e 100644
--- a/dev-python/python3-saml/Manifest
+++ b/dev-python/python3-saml/Manifest
@@ -1,2 +1,3 @@
DIST python3-saml-1.11.0.tar.gz 506373 BLAKE2B 909244e18b6ccb3cd0ed0059e387c14eb75a1a0fb709bdbc33f6dbcdda5b70359e6fedd77ab88e580aaf28503ca3f3fe49308f56338a1d8855149a7ba992034d SHA512 9e54eee28e2b6430d9f08342c312997b6a20f85e3f663573b93c4d8d65a6540c7d6f4e05d35314014b20ba080110a2a51718ac6754ef2b19bfe23d2d4381de24
DIST python3-saml-1.13.0.gh.tar.gz 509986 BLAKE2B e7c1720683f0391fe943de6ac95c69605a9e1499cf68d9bc416b56390bb5a4f16b17722aad4f6af2cf018195251554ebcc27a10a1605529fd3c98dd37efa4fea SHA512 e13325cdb2857d95ebd34dc4417f7929a76d1afdeb11972ef2fe3719c2db210137c5fef2c5dd4c09bd4dc467aa76afe5cbf14015f7eaf0941b369487313d3c97
+DIST python3-saml-1.14.0.gh.tar.gz 510031 BLAKE2B 10c1102b29b58017a39241dbab7d2fb85231f051e3701ff24197f2e501ae19b1889d4032fe86a60ed5ee708380d44111dc6ab87900c8463a141ea911fe774eeb SHA512 6807a4741164dfdf185a4c63691d5a1f0e91feff387265dc8b54b135d44158c751c2274eb1f47eb71d61c7e233d38ddc83f34d092cb842676830699ad6ee8af4
diff --git a/dev-python/python3-saml/python3-saml-1.14.0.ebuild b/dev-python/python3-saml/python3-saml-1.14.0.ebuild
new file mode 100644
index 000000000000..a74a6b60696b
--- /dev/null
+++ b/dev-python/python3-saml/python3-saml-1.14.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="OneLogin's SAML Python Toolkit"
+HOMEPAGE="https://github.com/onelogin/python3-saml
+ https://pypi.org/project/python3-saml/"
+SRC_URI="
+ https://github.com/onelogin/python3-saml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/isodate-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmlsec-1.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # unpin deps
+ sed -e '/lxml/s/</>=/' -i setup.py || die
+ distutils-r1_src_prepare
+}