summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-15 06:22:34 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-15 11:22:19 +0200
commitaa50a0c7092e2f089a1b7d37d4b4bf9170ef2656 (patch)
treeb6de333454864291c908bf4c331f6c055557ebc3 /dev-python/pythran
parentprofiles/package.mask: mask dev-ruby/spork for removal (diff)
downloadgentoo-aa50a0c7092e2f089a1b7d37d4b4bf9170ef2656.tar.gz
gentoo-aa50a0c7092e2f089a1b7d37d4b4bf9170ef2656.tar.bz2
gentoo-aa50a0c7092e2f089a1b7d37d4b4bf9170ef2656.zip
dev-python/pythran: Bump to 0.9.12.post1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/Manifest1
-rw-r--r--dev-python/pythran/pythran-0.9.12_p1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index a052b3a876eb..dc97c8284bbb 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -1 +1,2 @@
DIST pythran-0.9.11.gh.tar.gz 3570395 BLAKE2B deada9a608ed3d883308389d5a6ddfee2f0f74ecc74f1fd87bcee75eecabcab2acd576425b8e92d6fc6b212377f1c7295e766db32082339c98670a964a49ea10 SHA512 c8939b918216803ad8e2a133b16f0d8ea939e4d87d07ddb1a3d131afb0ddb76962c489270431808fbf129e76b5f9dbdc2b625097f37df2eefdb9834d319d028a
+DIST pythran-0.9.12.post1.gh.tar.gz 3612135 BLAKE2B 1c0650d249a0834a488aba6f48d1130b8897b4b220523d3aaa0f7557609f9cfcc208563980b6855132199fd394b45404c4c15c961380ea2089121c5c9eea65b2 SHA512 71a9dec2ca9eca85a2b3e52022e262135b4f1642d646bfc66323bd8b7545a11351d70aaec0fd90d82dc0ba23ec6733a30c8d807e5d90ff5c208d2995a6ac6f83
diff --git a/dev-python/pythran/pythran-0.9.12_p1.ebuild b/dev-python/pythran/pythran-0.9.12_p1.ebuild
new file mode 100644
index 000000000000..6cf9f49801e9
--- /dev/null
+++ b/dev-python/pythran/pythran-0.9.12_p1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 multiprocessing
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Ahead of Time compiler for numeric kernels"
+HOMEPAGE="
+ https://pypi.org/project/pythran/
+ https://github.com/serge-sans-paille/pythran/"
+SRC_URI="
+ https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
+ =dev-python/gast-0.5*[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/cblas
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}