summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-08-15 14:37:27 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-08-15 14:37:27 +0200
commit3bb8bc7bf8957952a82ed24f81c1480276b395ad (patch)
tree93370c7b61e5b1bc098e23835f3842c525b0f4e5 /dev-python/pytoml/pytoml-0.1.14.ebuild
parentnet-im/openmittsu: Add USE dependency on dev-qt/qtnetwork-5.7.1:5=[ssl]. (diff)
downloadgentoo-3bb8bc7bf8957952a82ed24f81c1480276b395ad.tar.gz
gentoo-3bb8bc7bf8957952a82ed24f81c1480276b395ad.tar.bz2
gentoo-3bb8bc7bf8957952a82ed24f81c1480276b395ad.zip
dev-python/pytoml: Initial version
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/pytoml/pytoml-0.1.14.ebuild')
-rw-r--r--dev-python/pytoml/pytoml-0.1.14.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytoml/pytoml-0.1.14.ebuild b/dev-python/pytoml/pytoml-0.1.14.ebuild
new file mode 100644
index 000000000000..4fbf49311c5f
--- /dev/null
+++ b/dev-python/pytoml/pytoml-0.1.14.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+TOML_TEST_COMMIT="fa9501a192b7c46b82059caddaef978e3de883dc"
+
+DESCRIPTION="A TOML-0.4.0 parser/writer for Python"
+HOMEPAGE="https://github.com/avakar/pytoml"
+SRC_URI="https://github.com/avakar/pytoml/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/avakar/toml-test/archive/${TOML_TEST_COMMIT}.tar.gz -> toml-test-${TOML_TEST_COMMIT}.tar.gz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cp -R ../toml-test-${TOML_TEST_COMMIT}/* test/toml-test/ || die
+ ${EPYTHON} test/test.py || die
+}