summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-04-03 23:07:16 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-04-03 23:07:16 +0200
commit75d89b95a3985e3723c3e1e64aac2a3919cefc6e (patch)
treefcff078b636e3c1917d11b0c686d580d6c80bfc2 /dev-python/pytz/pytz-2016.3.ebuild
parentdev-python/psutil: Version bump to 4.1.0 (diff)
downloadgentoo-75d89b95a3985e3723c3e1e64aac2a3919cefc6e.tar.gz
gentoo-75d89b95a3985e3723c3e1e64aac2a3919cefc6e.tar.bz2
gentoo-75d89b95a3985e3723c3e1e64aac2a3919cefc6e.zip
dev-python/pytz: Version bump to 2016.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/pytz/pytz-2016.3.ebuild')
-rw-r--r--dev-python/pytz/pytz-2016.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytz/pytz-2016.3.ebuild b/dev-python/pytz/pytz-2016.3.ebuild
new file mode 100644
index 000000000000..55874844f570
--- /dev/null
+++ b/dev-python/pytz/pytz-2016.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="http://pythonhosted.org/pytz/ https://pypi.python.org/pypi/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=sys-libs/timezone-data-2015g"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}"/${PN}-2009j-zoneinfo.patch
+ # ...and do not install a copy of it.
+ "${FILESDIR}"/${PN}-2009h-zoneinfo-noinstall.patch
+)
+
+python_test() {
+ "${PYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}