summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 15:03:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 15:11:38 +0200
commit61874df9d96980dd4c022316641262461670ad28 (patch)
treea9b2424064ed6266f4d7c95c9cf52f1cf0c0bcf7 /dev-python/pytz/pytz-2020.1.ebuild
parentdev-python/iso8601: Remove python2 (diff)
downloadgentoo-61874df9d96980dd4c022316641262461670ad28.tar.gz
gentoo-61874df9d96980dd4c022316641262461670ad28.tar.bz2
gentoo-61874df9d96980dd4c022316641262461670ad28.zip
dev-python/pytz: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytz/pytz-2020.1.ebuild')
-rw-r--r--dev-python/pytz/pytz-2020.1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/pytz/pytz-2020.1.ebuild b/dev-python/pytz/pytz-2020.1.ebuild
deleted file mode 100644
index 9b85408af154..000000000000
--- a/dev-python/pytz/pytz-2020.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="World timezone definitions for Python"
-HOMEPAGE="https://pythonhosted.org/pytz/ https://pypi.org/project/pytz/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE=""
-
-RDEPEND="
- || ( >=sys-libs/timezone-data-2017a sys-libs/glibc[vanilla] )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-PATCHES=(
- # Use timezone-data zoneinfo.
- "${FILESDIR}"/2018.4-zoneinfo.patch
- # ...and do not install a copy of it.
- "${FILESDIR}"/${PN}-2018.4-zoneinfo-noinstall.patch
-)
-
-python_test() {
- "${EPYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
-}