summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-09 10:19:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-09 16:44:15 +0200
commit03b481085bc20e6c9ea57a15335054256eb33cb4 (patch)
treebdcf09897416a95e44fd0401669b31dcf123a6c3 /dev-python/pytzdata/pytzdata-2020.1-r1.ebuild
parentsys-devel/clang-runtime: Bump to 12.0.1 (final) (diff)
downloadgentoo-03b481085bc20e6c9ea57a15335054256eb33cb4.tar.gz
gentoo-03b481085bc20e6c9ea57a15335054256eb33cb4.tar.bz2
gentoo-03b481085bc20e6c9ea57a15335054256eb33cb4.zip
dev-python/pytzdata: Use system zoneinfo by default
Closes: https://bugs.gentoo.org/801280 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytzdata/pytzdata-2020.1-r1.ebuild')
-rw-r--r--dev-python/pytzdata/pytzdata-2020.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytzdata/pytzdata-2020.1-r1.ebuild b/dev-python/pytzdata/pytzdata-2020.1-r1.ebuild
new file mode 100644
index 000000000000..d6192adb5e3a
--- /dev/null
+++ b/dev-python/pytzdata/pytzdata-2020.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The Olson timezone database for Python"
+HOMEPAGE="https://github.com/sdispater/pytzdata"
+SRC_URI="https://github.com/sdispater/pytzdata/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-python/cleo[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/pytzdata-2020.1-system-zoneinfo.patch
+)